QT-cute QuickTalk Guestbook 1.6 - Multiple Cross-Site Scripting Vulnerabilities

2008-05-02T00:00:00
ID EDB-ID:31720
Type exploitdb
Reporter ZoRLu
Modified 2008-05-02T00:00:00

Description

QT-cute QuickTalk Guestbook 1.6 Multiple Cross-Site Scripting Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/29013/info

QT-cute QuickTalk Guestbook is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

QuickTalk Guestbook 1.6 is vulnerable; other versions may also be affected.

http://www.example.com/quicktalk/qtf_cmd.php?a=[XSS]
http://www.example.com/quicktalk/qtf_ind_search_kw.php?title=[XSS]
http://www.example.com/quicktalk/qtf_ind_search_ov.php?a=[XSS]
http://www.example.com/quicktalk/qtf_ind_search_ov.php?a=user&id=2&n=[XSS]
http://www.example.com/quicktalk/qtf_ind_search_ov.php?a=user&id=[XSS]
http://www.example.com/quicktalk/qtf_ind_search_kw.php?title=adasdasdadasda&f=-1&al=0&at=0&s=[XSS]
http://www.example.com/quicktalk/qtf_ind_stat.php?y=[XSS]
http://www.example.com/quicktalk/qtf_ind_post.php?f=1&t=1[XSS]
http://www.example.com/quicktalk/qtf_adm_cmd.php?a=[XSS]