Blackboard Academic Suite 6/7 - bin/common/announcement.pl data__announcements___pk1_pk2__subject Parameter XSS

2008-03-26T00:00:00
ID EDB-ID:31538
Type exploitdb
Reporter Knight4vn
Modified 2008-03-26T00:00:00

Description

Blackboard Academic Suite 6/7 bin/common/announcement.pl data__announcementspk1pk2subject Parameter XSS. CVE-2008-1795. Webapps exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/28455/info
 
Blackboard Academic Suite is prone to multiple cross-site scripting vulnerabilities because the application fails to properly sanitize user-supplied input.
 
An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.
 
Blackboard versions prior to 6.3.1.683, 7.0.404.58, 7.1.467.35, 7.2.383.45, and 7.3.216.0 are vulnerable.

http://www.example.com/bin/common/announcement.pl?action=ADD&course_id=_137839_1&render_type=EDITABLE&context=course<input type="text" name="data__announcements___pk1_pk2__subject"value=?<script>alert(?worm activated!?)</script>? />