Atom PhotoBlog 1.0.1/1.0.9AtomPhotoBlog.PHP Multiple Input Validation Vulnerabilities

2007-06-07T00:00:00
ID EDB-ID:30161
Type exploitdb
Reporter Serapis.net
Modified 2007-06-07T00:00:00

Description

Atom PhotoBlog 1.0.1/1.0.9AtomPhotoBlog.PHP Multiple Input Validation Vulnerabilities. CVE-2007-3134 . Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/24363/info

Atom PhotoBlog is prone to multiple input-validation vulnerabilities because it fails to adequately sanitize user-supplied input data before rendering it in a user's browser. These issues include multiple HTML-injection vulnerabilities and a cross-site scripting vulnerability.

Attackers could exploit these issues to steal cookie-based authentication credentials from legitimate users of the site; other attacks are also possible.

Versions prior to Atom PhotoBlog 1.0.9.1 are vulnerable.

http://www.example.com/atomphotoblog/atomPhotoBlog.php?do=index&tag=<ScRiPt%20%0a%0d>alert(1566213939)%3B</ScRiPt>