Advanced Guestbook 2.4.2 Picture.PHP Cross-Site Scripting Vulnerability

2007-05-08T00:00:00
ID EDB-ID:29965
Type exploitdb
Reporter Jesper Jurcenoks
Modified 2007-05-08T00:00:00

Description

Advanced Guestbook 2.4.2 Picture.PHP Cross-Site Scripting Vulnerability. CVE-2007-0605. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/23873/info

Advanced Guestbook is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

This issue affects Advanced Guestbook 2.4.2; other versions may also be affected. 

http://www.example.com/picture.php?size[0]=1&size[1]=1&img=1&picture=[xss]