4Images 1.7 Details.PHP Cross-Site Scripting Vulnerability

2006-10-12T00:00:00
ID EDB-ID:28794
Type exploitdb
Reporter Christian Marthen
Modified 2006-10-12T00:00:00

Description

4Images 1.7 Details.PHP Cross-Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/20488/info

4images is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Version 1.7.3 is vulnerable; other versions may also be affected.

www.example.com/details.php?image_id=3&mode=%22%3E%3Ciframe%20src%3Dhttp%3A%2F%2Fwww.google.de%20width%3D150%20height%3D%22150