PHP Event Calendar 1.4/1.5 Index.PHP Multiple Cross-Site Scripting Vulnerabilities

2006-09-13T00:00:00
ID EDB-ID:28565
Type exploitdb
Reporter NR Nandini
Modified 2006-09-13T00:00:00

Description

PHP Event Calendar 1.4/1.5 Index.PHP Multiple Cross Site Scripting Vulnerabilities. CVE-2006-4825. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/20001/info

PHP Event Calendar is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied data.

Exploiting these issues could allow an attacker to steal cookie-based authentication credentials and to launch other attacks.

Version 1.5.1 is vulnerable; other versions may also be affected.

http://www.example.com/directory_where_you_installed_php_event_calendar/cl_files/index.php Vulnerable fields: title field - ti body field - bi Backgroung Image - cbgi Insert "<script>alert('XSS Vulnerable');</script>" in above field and click "Add event".