ModernBill 4.3 User.PHP SQL Injection Vulnerability

2006-04-19T00:00:00
ID EDB-ID:27678
Type exploitdb
Reporter r0t
Modified 2006-04-19T00:00:00

Description

ModernBill 4.3 User.PHP SQL Injection Vulnerability. CVE-2006-1853 . Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/17596/info

ModernBill is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query. 

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

http://www.example.com/user.php?op=menu&tile=mysupport&type=view&id=1[SQL]
http://www.example.com/user.php?op=menu&tile=mysupport&type=details&id=(existing id number)[SQL]
http://www.example.com/user.php?op=client_invoice&db_table=client_invoice&tile=myinvoices&print=&id=invoice_id|2869[SQL]