phpLinks 2.1.2/2.1.3 Index.PHP Cross-Site Scripting Vulnerability

2006-04-18T00:00:00
ID EDB-ID:27673
Type exploitdb
Reporter r0t
Modified 2006-04-18T00:00:00

Description

phpLinks 2.1.2/2.1.3 Index.PHP Cross-Site Scripting Vulnerability. CVE-2006-1825. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/17586/info

The phpLinks application is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. 

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Versions 2.1.3.1 and prior are vulnerable to this issue; other versions may also be affected.

http://www.example.com/phpLinks_path/index.php?logic=or&maximum=&term=%22%3Cscript%3Ealert('r0t')%3C/script%3E