Phpclanwebsite 1.23.1 BBCode IMG Tag Script Injection Vulnerability

2005-12-28T00:00:00
ID EDB-ID:27109
Type exploitdb
Reporter kurdish hackers team
Modified 2005-12-28T00:00:00

Description

Phpclanwebsite 1.23.1 BBCode IMG Tag Script Injection Vulnerability. CVE-2006-0366. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/16300/info

Phpclanwebsite is prone to a script-injection vulnerability.

An attacker can nest BBCode IMG tags to trigger this issue and execute arbitrary code in a user's browser.

Attacker-supplied HTML and script code would be able to access properties of the site, potentially allowing for theft of cookie-based authentication credentials. Other attacks are also possible.

Reports have not specified which version is vulnerable. The current version (1.23.1) is assumed to be vulnerable; other versions may also be affected.

The following proof of concept is available:

[img]javascript:alert('XSS')[/img]