E-Publish 2.0 - Multiple Input Validation Vulnerabilities

2005-12-19T00:00:00
ID EDB-ID:26910
Type exploitdb
Reporter r0t3d3Vil
Modified 2005-12-19T00:00:00

Description

E-Publish 2.0 Multiple Input Validation Vulnerabilities. Webapps exploit for cfm platform

                                        
                                            source: http://www.securityfocus.com/bid/15964/info

E-Publish is prone to multiple input validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

Successful exploitation of these vulnerabilities could result in a compromise of the application, disclosure or modification of data, the theft of cookie-based authentication credentials. They may also permit an attacker to exploit vulnerabilities in the underlying database implementation as well as other attacks.

This issue reportedly affects version 2.0 of E-Publish; other versions may also be affected. 

http://www.example.com/printer_friendly.cfm?id=[SQL]
http://www.example.com/show.cfm?id=274&obcatid=10[XSS]
http://www.example.com/show.cfm?id=279&how=5&obcatid=9&shfrm=1&comid=[XSS]