IHTML Merchant 2.0 - SQL Injection Vulnerability

2005-12-16T00:00:00
ID EDB-ID:26856
Type exploitdb
Reporter r0t3d3Vil
Modified 2005-12-16T00:00:00

Description

IHTML Merchant 2.0 SQL Injection Vulnerability. CVE-2005-4331. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/15911/info

iHTML Merchant is prone to an SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation. 

http://www.example.com/merchant.ihtml?id=56&step=[SQL]
http://www.example.com/merchant.ihtml?id=[SQL]
http://www.example.com/merchant.ihtml?pid=[SQL]