DMANews 0.9 - Multiple SQL Injection Vulnerabilities

2005-11-29T00:00:00
ID EDB-ID:26649
Type exploitdb
Reporter r0t
Modified 2005-11-29T00:00:00

Description

DMANews 0.9 Multiple SQL Injection Vulnerabilities. CVE-2005-3956. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/15628/info

DMANews is prone to multiple SQL injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

Versions 0.904 and 0.910 are vulnerable; other versions may also be affected. 

http://www.example.com/index.php?action=comments&id=[sq]
http://www.example.com/index.php?action=news_list&display_num=[sql]
http://www.example.com/index.php?action=news_list&sortorder=[sql]