Qualiteam X-Cart 4.0.8 product.php Multiple Parameter XSS

2005-05-30T00:00:00
ID EDB-ID:25760
Type exploitdb
Reporter CENSORED Search Vulnerabilities
Modified 2005-05-30T00:00:00

Description

Qualiteam X-Cart 4.0.8 product.php Multiple Parameter XSS. CVE-2005-1823. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/13817/info
 
X-Cart is prone to SQL injection and cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.
 
These vulnerabilities could permit remote attackers to pass malicious input to database queries, resulting in modification of query logic or other attacks. Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation. An attacker may also steal cookie-based authentication credentials and carry out other attacks.
 
X-Cart 4.0.8 is reportedly vulnerable. Other versions may be affected as well. 

http://www.example.com/product.php?productid='><script>alert(document.cookie)</script>
http://www.example.com/product.php?mode='><script>alert(document.cookie)</script>