Advanced Guestbook 2.3.1/2.4 Index.PHP Entry Parameter SQL Injection Vulnerability

2005-05-09T00:00:00
ID EDB-ID:25630
Type exploitdb
Reporter Spy Hat
Modified 2005-05-09T00:00:00

Description

Advanced Guestbook 2.3.1/2.4 Index.PHP Entry Parameter SQL Injection Vulnerability. CVE- 2005-1548. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/13548/info

Advanced Guestbook is prone to an SQL-injection vulnerability because it fails to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

This issue reportedly affects Advanced Guestbook version 2.3.1; other versions may also be vulnerable. 

http://www.example.com/guestbook/index.php?entry='
http://www.example.com/guestbook/index.php?entry=%27