paFaq beta4 question.php Multiple Parameter SQL Injection

2005-02-17T00:00:00
ID EDB-ID:25114
Type exploitdb
Reporter pi3ch
Modified 2005-02-17T00:00:00

Description

paFaq beta4 question.php Multiple Parameter SQL Injection. CVE-2005-0475. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/12582/info

paFaq is reportedly affected by an SQL injection vulnerability. This issue exists because the application fails to properly sanitize user-supplied input before using it in SQL queries.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

This vulnerability is reported to affect paFaq beta4; earlier versions may also be affected. 

http://www.example.com/index.php?act=Question&id=1&limit=10&orderby=q_id&order=DESC&offset='
http://www.example.com/index.php?act=Question&id=1&orderby=q_id&order=DESC&limit='
http://www.example.com/index.php?act=Question&id=1&orderby=q_id&order='&limit=10
http://www.example.com/index.php?act=Question&id=1&orderby='&order=DESC&limit=10