PsychoStats 2.x Login Parameter Cross-Site Scripting Vulnerability

2004-12-22T00:00:00
ID EDB-ID:25048
Type exploitdb
Reporter James Bercegay
Modified 2004-12-22T00:00:00

Description

PsychoStats 2.x Login Parameter Cross-Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/12089/info

PsychoStats is reported prone to a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

The problem presents itself when malicious HTML and script code is sent to the application through the 'login' parameter.

This vulnerability may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in PsychoStats 2.2.4 Beta and prior versions. 

http://www.example.com/stats/login.php?login=%22%3E%3Ciframe%3E