ABC2MIDI 2004-12-04 - Multiple Stack Buffer Overflow Vulnerabilities

2004-12-15T00:00:00
ID EDB-ID:25019
Type exploitdb
Reporter Limin Wang
Modified 2004-12-15T00:00:00

Description

ABC2MIDI 2004-12-04 Multiple Stack Buffer Overflow Vulnerabilities. CVE-2004-1256 . Remote exploits for multiple platform

                                        
                                            source: http://www.securityfocus.com/bid/12019/info

It is reported that abc2midi is susceptible to two stack buffer overflow vulnerabilities. These issues are due to a failure of the application to properly bounds check user-supplied image data prior to copying it into fixed-size memory buffers.

These vulnerabilities allow remote attackers to alter the proper flow of execution of the application, potentially resulting in the execution of attacker-supplied machine code in the context of the application attempting to read malicious ABC files. 

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/25019-1.zip

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/25019-2.zip