MPG123 0.59 Find Next File Remote Client-Side Buffer Overflow Vulnerability

2004-12-15T00:00:00
ID EDB-ID:24852
Type exploitdb
Reporter Bartlomiej Sieka
Modified 2004-12-15T00:00:00

Description

MPG123 0.59 Find Next File Remote Client-Side Buffer Overflow Vulnerability. CVE-2004-1284. Remote exploit for linux platform

                                        
                                            source: http://www.securityfocus.com/bid/11958/info

A remote client-side buffer overflow vulnerability affects mpg123. This issue is due to a failure of the application to properly validate the length of user-supplied strings prior to copying them into static process buffers.

An attacker may exploit this issue to execute arbitrary code with the privileges of the user that activated the vulnerable application. This may facilitate unauthorized access or privilege escalation.

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/24852.list