PhpGedView 2.5/2.6 Gedrecord.PHP Cross-Site Scripting Vulnerability

2004-01-12T00:00:00
ID EDB-ID:24821
Type exploitdb
Reporter JeiAr
Modified 2004-01-12T00:00:00

Description

PhpGedView 2.5/2.6 Gedrecord.PHP Cross-Site Scripting Vulnerability. CVE-2004-0067. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/11891/info

It is reported that PhpGedView is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/phpgedview/gedrecord.php?pid=<iframe>