BoardPower Forum ICQ.CGI Cross-Site Scripting Vulnerability

2004-07-15T00:00:00
ID EDB-ID:24287
Type exploitdb
Reporter Alexander Antipov
Modified 2004-07-15T00:00:00

Description

BoardPower Forum ICQ.CGI Cross-Site Scripting Vulnerability. CVE-2004-1441. Webapps exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/10734/info

BoardPower Forum is reportedly affected by a cross-site scripting vulnerability in the icq.cgi script. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

A remote attacker can exploit this issue by creating a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the web server and may allow for theft of cookie-based authentication credentials or other attacks. 

http://www.example.com/cgi-bin/boardpower/icq.cgi?action=<script>javascript:alert('hello');</script>