OpenBB 1.0.x board.php FID Parameter SQL Injection

2004-04-26T00:00:00
ID EDB-ID:24056
Type exploitdb
Reporter JeiAr
Modified 2004-04-26T00:00:00

Description

OpenBB 1.0.x board.php FID Parameter SQL Injection. CVE-2004-1966. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/10214/info
    
It has been reported that OpenBB is affected by multiple input validation vulnerabilities. These issues are due to a failure of the application to properly sanitize user supplied user input.
    
The SQL issues may allow a remote attacker to manipulate query logic, potentially leading to unauthorized access to sensitive information such as the administrator password hash or corruption of database data. SQL injection attacks may also potentially be used to exploit latent vulnerabilities in the underlying database implementation.
    
The cross-site scripting issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/board.php?FID=1[SQL]