SpiderSales 2.0 Shopping Cart Multiple Vulnerabilities

2004-03-03T00:00:00
ID EDB-ID:23791
Type exploitdb
Reporter Nick Gudov
Modified 2004-03-03T00:00:00

Description

SpiderSales 2.0 Shopping Cart Multiple Vulnerabilities. CVE-2004-0348. Webapps exploit for asp platform

                                        
                                            source: http://www.securityfocus.com/bid/9799/info

Multiple vulnerabilities have been identified in the application that may allow an attacker to obtain the private cryptographic key and gain access to sensitive information. The application is also reported prone to an SQL injection vulnerability that may allow an attacker to gain administrative level access to the underlying database.

The issues exist due to improper implementation of the RSA cryptosystem by SpiderSales and failure to sanitize user-supplied input via the 'userId' URI parameter employed by various scripts.

SpiderSales version 2.0 is assumed to be vulnerable to these issues, however, other versions could be affected as well.

http://www.example.com/Carts/Computers/viewCart.asp?userID=2893225125722634';exec%20master..xp_cmdshell%20'dir%20c:%20>%20c:\inetpub\wwwroot\dirc.txt'--&viewID=48