TinyServer 1.1 - Cross-Site scripting

ID EDB-ID:23596
Type exploitdb
Reporter Donato Ferrante
Modified 2004-01-24T00:00:00


TinyServer 1.1 Cross-site scripting. CVE-2004-2119. Remote exploit for windows platform

                                            source: http://www.securityfocus.com/bid/9485/info
TinyServer is prone to multiple vulnerabilities.
A directory traversal issue is present in TinyServer that could allow a remote user to view or download any file to which the server has access.
A denial of service issue exists due to the failure of the server to check input strings received. Attackers can crash the server by simply sending malformed HTTP GET requests. Sending an HTTP GET request with excessively long data can also cause the server to fail. It is not known if this issue may also result in code execution.
A cross-site scripting issue is also present in the server. This could allow for theft of cookie-based authentication credentials or other attacks.