Acme thttpd 1.9/2.0.x CGI Test Script Cross-Site Scripting Vulnerability

2004-01-22T00:00:00
ID EDB-ID:23582
Type exploitdb
Reporter Rafel Ivgi The-Insider
Modified 2004-01-22T00:00:00

Description

Acme thttpd 1.9/2.0.x CGI Test Script Cross-Site Scripting Vulnerability. CVE-2004-2102. Remote exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/9474/info

thttpd is prone to a cross-site scripting vulnerability in the CGI test script. This could permit a remote attacker to create a malicious link to the web server that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the web server and may allow for theft of cookie-based authentication credentials or other attacks.

It should be noted that FREESCO includes an embedded version of thttpd and is also prone to this vulnerability. 

http://www.example.com/cgi/example?test=<script>alert('xss')</script>