IBM Directory Server 4.1 Web Administration Interface Cross-Site Scripting Vulnerability

2003-12-02T00:00:00
ID EDB-ID:23410
Type exploitdb
Reporter Oliver Karow
Modified 2003-12-02T00:00:00

Description

IBM Directory Server 4.1 Web Administration Interface Cross-Site Scripting Vulnerability. Webapps exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/9140/info

IBM Directory Server is prone to cross-site scripting attacks via the web administrative interface. An attacker may be able to embed hostile HTML and script code in a malicious link to the server, which when followed will be rendered in the victim user's browser. This could allow the attacker to steal cookie-based authentication credentials or to launch other attacks.

This issue was reported in Directory Server 4.1. Other versions may also be affected. 

https://www.example.com/ldap/cgi-bin/ldacgi.exe?Action=<script>alert("foo")</script>