ncube server manager 1.0 - Directory Traversal Vulnerability

2003-11-10T00:00:00
ID EDB-ID:23370
Type exploitdb
Reporter Beck Mr.R
Modified 2003-11-10T00:00:00

Description

nCube Server Manager 1.0 Directory Traversal Vulnerability. Webapps exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/9004/info

nCUBE Server Manager has been reported prone to a directory traversal vulnerability. The issue presents itself likely due to a lack of sufficient sanitization performed on URI parameters. A remote attacker may exploit this condition by supplying directory traversal sequences as a value for the affected URI parameter passed to a Server Manager script. Ultimately this may allow the attacker to break out of the webserver root and view arbitrary directory listings and potentially arbitrary files on the vulnerable system.

http://example.com/cgi-bin/nph-showlogs.pl?files=../../&filter=.*&submit=Go&linecnt=500&refresh=0