Macromedia ColdFusion MX 6.0 - SQL Error Message Cross-Site Scripting Vulnerability

2003-10-15T00:00:00
ID EDB-ID:23256
Type exploitdb
Reporter Lorenzo Hernandez Garcia-Hierro
Modified 2003-10-15T00:00:00

Description

Macromedia ColdFusion MX 6.0 SQL Error Message Cross-Site Scripting Vulnerability. Webapps exploit for cfm platform

                                        
                                            source: http://www.securityfocus.com/bid/8840/info

It has been reported that Macromedia ColdFusion MX may be prone to a cross-site scripting vulnerability due to improper handling of error messages generated by the underlying database. This problem may be exploited by an attacker to construct a malicious link containing HTML or script code that may be rendered in a user's browser upon visiting that link. If successful, an attacker may obtain access to cookie-based authentication credentials that may lead to other attacks. This attack would occur in the security context of the vulnerable site.

Macromedia ColdFusion MX version 6.0 may be vulnerable to this issue, however other versions may be affected as well. 

http://www.example.com/article.cfm?id=1'<script>alert(document.cookie);</script>