Atrise Everyfind 5.0.2 - search Cross-Site Scripting Vulnerability

2003-10-01T00:00:00
ID EDB-ID:23207
Type exploitdb
Reporter Ezhilan
Modified 2003-10-01T00:00:00

Description

Atrise Everyfind 5.0.2 search Cross-Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/8740/info

It has been reported that Atrise Everyfind is prone to a cross-site scripting vulnerability due to insufficient sanitization of user-supplied input. The problem exists in the search module of the software. This issue may allow a remote attacker to execute HTML or script code in user's browser.

Successful exploitation of this vulnerability may allow an attacker to steal cookie-based authentication credentials. Other attacks may well be possible.

Atrise Everyfind 5.02 has been listed as a vulnerable package, however other versions may be affected as well. 

http://www.example.com/search.html?cat=0&keys=<script>alert("hello")</script><script>alert.document.cookie)</script>