WebChat 2.0 Users.PHP Cross-Site Scripting Vulnerability

ID EDB-ID:22716
Type exploitdb
Reporter Rynho Zeros Web
Modified 2003-06-02T00:00:00


WebChat 2.0 Users.PHP Cross-Site Scripting Vulnerability. Webapps exploit for php platform

                                            source: http://www.securityfocus.com/bid/7779/info

WebChat has been reported prone to a cross-site scripting vulnerability.

WebChat does not adequately filter script code from URI parameters, making it prone to cross-site scripting attacks. Attacker-supplied script code may be included in a malicious link to the WebChat 'users.php' script.

This may enable a remote attacker to steal cookie-based authentication credentials from legitimate users. Other attacks are also possible.

This vulnerability was reported to affect WebChat version 2.0 other versions may also be affected.