Mod_NTLM 0.x - Authorization Heap Overflow Vulnerability

ID EDB-ID:22512
Type exploitdb
Reporter Matthew Murphy
Modified 2003-04-21T00:00:00


Mod_NTLM 0.x Authorization Heap Overflow Vulnerability. Dos exploits for multiple platform


The mod_ntlm Apache module has been reported prone to a heap overflow vulnerability.

The vulnerability occurs due to a lack of sufficient bounds checking performed on user-supplied data, stored in heap memory. By supplying excessive data an attacker may trigger a buffer overflow and corrupt crucial memory management structures. This may result in the execution of arbitrary code in the context of the Apache server.

This vulnerability is reported to affect mod_ntlm <= v0.4 for Apache 1.3 and mod_ntlmv2 version 0.1 for Apache 2.0. 

GET / HTTP/1.0
Authorization: [Ax3000]